aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..0c69f2c
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "files"
+version = "0.1.0"
+authors = ["Joris <joris@guyonvarch.me>"]
+edition = "2021"
+
+[dependencies]
+base64 = "0.22"
+chrono = "0.4"
+const_format = "0.2"
+env_logger = "0.11"
+futures-util = "0.3"
+html-escape = "0.2"
+http-body-util = "0.1"
+hyper = { version = "1", features = ["full"] }
+hyper-util = { version = "0.1", features = ["full"] }
+log = "0.4"
+rand = { version = "0.8", features = ["getrandom"] }
+rand_core = "0.6.0"
+tempfile = "3.10"
+tokio = { version = "1", features = ["full"] }
+tokio-rusqlite = "0.5.1"
+tokio-util = "0.7"