diff options
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 29 |
1 files changed, 21 insertions, 8 deletions
@@ -1,17 +1,30 @@ -with import <nixpkgs> {}; +with import (builtins.fetchGit { + name = "nixpkgs-20.09"; + url = "git@github.com:nixos/nixpkgs.git"; + rev = "cd63096d6d887d689543a0b97743d28995bc9bc3"; + ref = "refs/tags/20.09"; +}) {}; -let unstable = import ( - fetchTarball https://github.com/NixOS/nixpkgs-channels/archive/nixos-unstable.tar.gz - ) {}; -in +let nixpkgs-mozilla = fetchFromGitHub { + owner = "mozilla"; + repo = "nixpkgs-mozilla"; + # commit from 2020-10-28 + rev = "8c007b60731c07dd7a052cce508de3bb1ae849b4"; + sha256 = "1zybp62zz0h077zm2zmqs2wcg3whg6jqaah9hcl1gv4x8af4zhs6"; +}; in + +with import "${nixpkgs-mozilla.out}/rust-overlay.nix" pkgs pkgs; mkShell { buildInputs = [ - entr + ((rustChannelOf { channel = "1.49.0"; }).rust.override { + targets = [ "wasm32-unknown-unknown" ]; + }) + psmisc # fuser gzip python3 - rustup - unstable.binaryen + binaryen wasm-pack + watchexec ]; } |