aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2016-07-14 11:57:12 +0000
committerJoris2016-07-14 12:00:05 +0000
commit69e69017b75d1cdaa1fd2aef2818de5111b29735 (patch)
tree99dba8f67dc1c55b2cc22f33f81c59c7355b337b /shell.nix
parent04f9a66c66ca137d9fee6ccca228c41fec960fe0 (diff)
downloadad-listener-69e69017b75d1cdaa1fd2aef2818de5111b29735.tar.gz
ad-listener-69e69017b75d1cdaa1fd2aef2818de5111b29735.tar.bz2
ad-listener-69e69017b75d1cdaa1fd2aef2818de5111b29735.zip
Update code and fix parsers
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..cc4be36
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,15 @@
+with import <nixpkgs> {}; {
+ env = stdenv.mkDerivation {
+ name = "env";
+ buildInputs = [
+ cabal-install
+ cabal2nix
+ tmux
+ tmuxinator
+ ];
+ shellHook = ''
+ tmux kill-session -t leboncoin-listener >/dev/null 2>&1
+ tmuxinator local
+ '';
+ };
+}