diff options
author | Joris | 2023-09-16 18:28:16 +0200 |
---|---|---|
committer | Joris | 2023-09-16 18:31:24 +0200 |
commit | 06f045e90bb57c36738e58ee6830e2a2391bc6a3 (patch) | |
tree | a5b65b048c103b4ea0e5d3c0fa5e115cbaf3cf5f /flake.nix | |
parent | 230f2e0623d22af6e68466884bd5dea5dcb846dc (diff) |
Migrate CLI to python
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 13 |
1 files changed, 11 insertions, 2 deletions
@@ -8,15 +8,24 @@ flake-utils.lib.eachDefaultSystem (system: let pkgs = import nixpkgs { inherit system; }; + + ebook-convert = with pkgs; writeShellScriptBin "ebook-convert" '' + set -euo pipefail + ${calibre}/bin/ebook-convert "$@" + ''; in with pkgs; { devShell = mkShell { buildInputs = [ esbuild nodePackages.typescript psmisc # fuser - python3 - toml2json watchexec + + # CLI + python311 + python311Packages.requests + python311Packages.pillow + ebook-convert ]; }; } |