aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJoris2023-01-21 14:10:47 +0100
committerJoris2023-01-21 14:10:47 +0100
commit25abf9bc7fd3e6f5b5aabf745cef7d217cde4262 (patch)
treed3ef6f2be1b117cfe5c75f5cd22408b2f47088f0 /flake.nix
parent424cabd49593b13470be1868cf75349b1830929c (diff)
Setup initial view of covers
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..d2e3a07
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,20 @@
+{
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = { self, nixpkgs, flake-utils, ... }:
+ flake-utils.lib.eachDefaultSystem (system:
+ let
+ pkgs = import nixpkgs { inherit system; };
+ in with pkgs; {
+ devShell = mkShell {
+ buildInputs = [
+ psmisc
+ watchexec
+ ];
+ };
+ }
+ );
+}