diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 13 |
1 files changed, 11 insertions, 2 deletions
@@ -8,15 +8,24 @@ flake-utils.lib.eachDefaultSystem (system: let pkgs = import nixpkgs { inherit system; }; + + ebook-convert = with pkgs; writeShellScriptBin "ebook-convert" '' + set -euo pipefail + ${calibre}/bin/ebook-convert "$@" + ''; in with pkgs; { devShell = mkShell { buildInputs = [ esbuild nodePackages.typescript psmisc # fuser - python3 - toml2json watchexec + + # CLI + python311 + python311Packages.requests + python311Packages.pillow + ebook-convert ]; }; } |