aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoris2021-01-03 13:40:40 +0100
committerJoris2021-01-03 13:54:20 +0100
commit11052951b74b9ad4b6a9412ae490086235f9154b (patch)
tree64526ac926c1bf470ea113f6cac8a33158684e8d /Cargo.toml
parent371449b0e312a03162b78797b83dee9d81706669 (diff)
downloadbudget-11052951b74b9ad4b6a9412ae490086235f9154b.tar.gz
budget-11052951b74b9ad4b6a9412ae490086235f9154b.tar.bz2
budget-11052951b74b9ad4b6a9412ae490086235f9154b.zip
Rewrite in Rust
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..3ae6867
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "budget"
+version = "0.1.0"
+authors = ["Joris <joris@guyonvarch.me>"]
+edition = "2018"
+
+[dependencies]
+bcrypt = "0.9"
+chrono = "0.4"
+env_logger = "0.8"
+hyper = "0.13"
+lettre = "0.9"
+lettre_email = "0.9"
+log = "0.4"
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+serde_urlencoded = "0.7"
+sha2 = "0.9"
+sqlx = { version = "0.4", features = ["runtime-tokio-rustls", "sqlite", "chrono"] }
+sqlx-core = "0.4"
+structopt = "0.3"
+tera = { version = "1.6", features = ["builtins"] }
+tokio = { version = "0.2", features = ["macros", "sync", "rt-threaded"] }
+tokio-util = { version = "0.3", features = ["codec"] }
+url = "2.2"
+uuid = { version = "0.8", features = ["v4"] }