aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoris2021-02-07 08:19:00 +0100
committerJoris2021-02-07 08:19:00 +0100
commit849aac0550aaab89a63dd71b954006809bfd1728 (patch)
tree14a706b6a9a2e255c7e7981414ef3493bc9092a5 /Cargo.toml
parenta8e943c9a7abbde95c900d89fc5f2ed825e9afa3 (diff)
downloadbudget-849aac0550aaab89a63dd71b954006809bfd1728.tar.gz
budget-849aac0550aaab89a63dd71b954006809bfd1728.tar.bz2
budget-849aac0550aaab89a63dd71b954006809bfd1728.zip
Upgrade dependencies
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index db6a0d9..3720235 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,17 +8,17 @@ edition = "2018"
bcrypt = "0.9"
chrono = "0.4"
env_logger = "0.8"
-hyper = "0.13"
+hyper = { version = "0.14", features = ["full"] }
log = "0.4"
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
serde_urlencoded = "0.7"
sha2 = "0.9"
-sqlx = { version = "0.4", features = ["runtime-tokio-rustls", "sqlite", "chrono"] }
-sqlx-core = "0.4"
+sqlx = { version = "0.5", features = ["runtime-tokio-rustls", "sqlite", "chrono"] }
+sqlx-core = "0.5"
structopt = "0.3"
tera = { version = "1.6", features = ["builtins"] }
-tokio = { version = "0.2", features = ["macros", "sync", "rt-threaded", "process"] }
-tokio-util = { version = "0.3", features = ["codec"] }
+tokio = { version = "1", features = ["full"] }
+tokio-util = { version = "0.6", features = ["codec"] }
url = "2.2"
uuid = { version = "0.8", features = ["v4"] }