aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJoris2021-11-12 17:37:03 +0100
committerJoris2021-11-12 17:37:03 +0100
commit2a275d17fbbe18c5ca74ee5c2ff2fb07a6fb84e2 (patch)
treed35542e208ee630762b0e421a38c8a52771779b3 /flake.nix
parent7aecb9500eabb7c17d8f9473eed62e6dd013161a (diff)
downloadbudget-2a275d17fbbe18c5ca74ee5c2ff2fb07a6fb84e2.tar.gz
budget-2a275d17fbbe18c5ca74ee5c2ff2fb07a6fb84e2.tar.bz2
budget-2a275d17fbbe18c5ca74ee5c2ff2fb07a6fb84e2.zip
Use nix flakes
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..15ec82b
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,32 @@
+{
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ flake-utils.url = "github:numtide/flake-utils";
+ rust-overlay.url = "github:oxalica/rust-overlay";
+ rust-overlay.inputs.nixpkgs.follows = "nixpkgs";
+ rust-overlay.inputs.flake-utils.follows = "flake-utils";
+ };
+
+ outputs = { self, nixpkgs, rust-overlay, flake-utils, ... }:
+ flake-utils.lib.eachDefaultSystem (system:
+ let
+ overlays = [ (import rust-overlay) ];
+ pkgs = import nixpkgs {
+ inherit system overlays;
+ };
+ in
+ with pkgs;
+ {
+ devShell = mkShell {
+ buildInputs = [
+ ((rustChannelOf { channel = "1.56.1"; }).rust)
+ cargo-watch
+ lld
+ openssl
+ pkgconfig
+ sqlite
+ ];
+ };
+ }
+ );
+}