aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2021-11-12 17:37:03 +0100
committerJoris2021-11-12 17:37:03 +0100
commit2a275d17fbbe18c5ca74ee5c2ff2fb07a6fb84e2 (patch)
treed35542e208ee630762b0e421a38c8a52771779b3 /shell.nix
parent7aecb9500eabb7c17d8f9473eed62e6dd013161a (diff)
downloadbudget-2a275d17fbbe18c5ca74ee5c2ff2fb07a6fb84e2.tar.gz
budget-2a275d17fbbe18c5ca74ee5c2ff2fb07a6fb84e2.tar.bz2
budget-2a275d17fbbe18c5ca74ee5c2ff2fb07a6fb84e2.zip
Use nix flakes
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/shell.nix b/shell.nix
deleted file mode 100644
index 043940c..0000000
--- a/shell.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-with import (builtins.fetchGit {
- name = "nixos-21.05-2021-10-09";
- url = "https://github.com/nixos/nixpkgs/";
- ref = "refs/heads/nixos-21.05";
- rev = "ce7a1190a0fa4ba3465b5f5471b08567060ca14c";
-}) {};
-
-let nixpkgs-mozilla = fetchFromGitHub {
- owner = "mozilla";
- repo = "nixpkgs-mozilla";
- # commit from 2021-07-17
- rev = "0510159186dd2ef46e5464484fbdf119393afa58";
- sha256 = "1zybp62zz0h077zm2zmqs2wcg3whg6jqaah9hcl1gv4x8af4zhs6";
-}; in
-
-with import "${nixpkgs-mozilla.out}/rust-overlay.nix" pkgs pkgs;
-
-pkgs.mkShell {
-
- buildInputs = [
- ((rustChannelOf { channel = "1.55.0"; }).rust)
- cargo-watch
- lld
- openssl
- pkgconfig
- sqlite
- ];
-
-}