aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2016-07-04 19:36:16 +0200
committerJoris2016-07-08 01:10:25 +0200
commit52f9fafc65d81fc8f684dee21f895e85a14c8165 (patch)
tree03ca065804084857fbd9ea852754424fd9b7a9c9 /shell.nix
parentec08c799d1c1a0713d0ac6140314335950a728d5 (diff)
downloadbudget-52f9fafc65d81fc8f684dee21f895e85a14c8165.tar.gz
budget-52f9fafc65d81fc8f684dee21f895e85a14c8165.tar.bz2
budget-52f9fafc65d81fc8f684dee21f895e85a14c8165.zip
Update getting started section in README
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
index 4a2046a..bb656a8 100644
--- a/shell.nix
+++ b/shell.nix
@@ -6,6 +6,25 @@ with import <nixpkgs> {}; {
cabal-install
cabal2nix
nodejs
+ sqlite
+ tmux
];
+ shellHook = ''
+ tmux kill-session -t sharedCost >/dev/null
+
+ urxvt -e zsh -c "tmux new-session -s sharedCost" & sleep 0.5
+ tmux send-keys -t sharedCost '"$EDITOR" README.md' 'C-m'
+
+ tmux split-window -h -t sharedCost
+ tmux send-keys -t sharedCost 'make install && make build && make watch' 'C-m'
+
+ tmux select-pane -t sharedCost -L
+ tmux resize-pane -t sharedCost -R 25
+
+ firefox http://localhost:3000/
+
+ sleep 0.5
+ kill -9 $PPID
+ '';
};
}