aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2016-07-02 16:26:12 +0200
committerJoris2016-07-02 16:26:12 +0200
commita04ec905da2c6a8640162a0d397e184ea1a8bc78 (patch)
treef77f0a6012d0a2cb2eb0316273d5d13e83815f43 /shell.nix
parentba33dfef23d070bfff92d6322808507c1b7d2814 (diff)
downloadbudget-a04ec905da2c6a8640162a0d397e184ea1a8bc78.tar.gz
budget-a04ec905da2c6a8640162a0d397e184ea1a8bc78.tar.bz2
budget-a04ec905da2c6a8640162a0d397e184ea1a8bc78.zip
Use nix to fetch dev tools
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..4a2046a
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,11 @@
+with import <nixpkgs> {}; {
+ env = stdenv.mkDerivation {
+ name = "env";
+ buildInputs = [
+ elmPackages.elm
+ cabal-install
+ cabal2nix
+ nodejs
+ ];
+ };
+}