aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2021-10-09 09:01:19 +0200
committerJoris2021-10-09 09:01:19 +0200
commita370f989fe3b864676ed9aecf57f70e55e7958b2 (patch)
treec5dcca86af883922f42fc161f350e8155c7c2740 /shell.nix
parent20c2b0ff6a4f60854e86ef2c34f8113e897a11bb (diff)
downloadbudget-a370f989fe3b864676ed9aecf57f70e55e7958b2.tar.gz
budget-a370f989fe3b864676ed9aecf57f70e55e7958b2.tar.bz2
budget-a370f989fe3b864676ed9aecf57f70e55e7958b2.zip
Upgrade dependencies
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix18
1 files changed, 9 insertions, 9 deletions
diff --git a/shell.nix b/shell.nix
index 6708ac8..043940c 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,15 +1,15 @@
-with (import (builtins.fetchGit {
- name = "nixpkgs-20.09";
- url = "git@github.com:nixos/nixpkgs.git";
- rev = "cd63096d6d887d689543a0b97743d28995bc9bc3";
- ref = "refs/tags/20.09";
-}){});
+with import (builtins.fetchGit {
+ name = "nixos-21.05-2021-10-09";
+ url = "https://github.com/nixos/nixpkgs/";
+ ref = "refs/heads/nixos-21.05";
+ rev = "ce7a1190a0fa4ba3465b5f5471b08567060ca14c";
+}) {};
let nixpkgs-mozilla = fetchFromGitHub {
owner = "mozilla";
repo = "nixpkgs-mozilla";
- # commit from 2020-10-28
- rev = "8c007b60731c07dd7a052cce508de3bb1ae849b4";
+ # commit from 2021-07-17
+ rev = "0510159186dd2ef46e5464484fbdf119393afa58";
sha256 = "1zybp62zz0h077zm2zmqs2wcg3whg6jqaah9hcl1gv4x8af4zhs6";
}; in
@@ -18,7 +18,7 @@ with import "${nixpkgs-mozilla.out}/rust-overlay.nix" pkgs pkgs;
pkgs.mkShell {
buildInputs = [
- ((rustChannelOf { channel = "1.49.0"; }).rust)
+ ((rustChannelOf { channel = "1.55.0"; }).rust)
cargo-watch
lld
openssl