aboutsummaryrefslogtreecommitdiff
path: root/stylish-haskell/default.nix
diff options
context:
space:
mode:
authorJoris2017-11-13 23:56:40 +0100
committerJoris2017-11-14 00:03:10 +0100
commit5a63f7be9375e3ab888e4232dd7ef72c2f1ffae1 (patch)
tree4884de1d03bc47ba8f06b2cf68365d9eed9e0d39 /stylish-haskell/default.nix
parent213cf7ede058b781fc957de2cd9f6a5988c08004 (diff)
downloadbudget-5a63f7be9375e3ab888e4232dd7ef72c2f1ffae1.tar.gz
budget-5a63f7be9375e3ab888e4232dd7ef72c2f1ffae1.tar.bz2
budget-5a63f7be9375e3ab888e4232dd7ef72c2f1ffae1.zip
Setup stylish-haskell
Diffstat (limited to 'stylish-haskell/default.nix')
-rw-r--r--stylish-haskell/default.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/stylish-haskell/default.nix b/stylish-haskell/default.nix
new file mode 100644
index 0000000..bd73cf8
--- /dev/null
+++ b/stylish-haskell/default.nix
@@ -0,0 +1,44 @@
+{ HUnit, aeson, base, bytestring, containers, directory, fetchFromGitHub
+, filepath, haskell-src-exts, mkDerivation, mtl, optparse-applicative, stdenv
+, strict, stylish-haskell, syb, test-framework, test-framework-hunit, yaml
+}:
+
+let regularDependencies = [
+ aeson
+ base
+ bytestring
+ containers
+ directory
+ filepath
+ haskell-src-exts
+ mtl
+ syb
+ yaml
+ ];
+in mkDerivation {
+ pname = "stylish-haskell";
+ version = "0.8.1.0";
+
+ src = fetchFromGitHub {
+ owner = "jaspervdj";
+ repo = "stylish-haskell";
+ rev = "dc3a73e82c19ff97a1544840dac8f7f4568b24bc";
+ sha256 = "0kx9m3j9w2357ff5y651s9cdbjiyax9fksyf4rk8pzabc0dv6dpg";
+ };
+
+ isLibrary = true;
+ isExecutable = true;
+
+ libraryHaskellDepends =
+ regularDependencies;
+
+ executableHaskellDepends =
+ regularDependencies ++ [ optparse-applicative strict stylish-haskell ];
+
+ testHaskellDepends =
+ regularDependencies ++ [ HUnit test-framework test-framework-hunit ];
+
+ homepage = "https://github.com/jaspervdj/stylish-haskell";
+ description = "Simple Haskell code prettifier";
+ license = stdenv.lib.licenses.bsd3;
+ }