aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9451df3..3320952 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,9 +5,9 @@ authors = ["Joris <joris@guyonvarch.me>"]
edition = "2021"
[dependencies]
-bcrypt = "0.14"
+bcrypt = "0.15"
chrono = "0.4"
-clap = { version = "4.2", features = ["derive"] }
+clap = { version = "4.3", features = ["derive"] }
env_logger = "0.10"
hmac = "0.12"
hex = "0.4"
@@ -19,10 +19,10 @@ serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
serde_urlencoded = "0.7"
sha2 = "0.10"
-sqlx = { version = "0.6", features = ["runtime-tokio-rustls", "sqlite", "chrono"] }
-sqlx-core = "0.6"
-tera = { version = "1.18", features = ["builtins"] }
+sqlx = { version = "0.7", features = ["runtime-tokio-rustls", "sqlite", "chrono"] }
+sqlx-core = "0.7"
+tera = { version = "1.19", features = ["builtins"] }
tokio = { version = "1", features = ["full"] }
tokio-util = { version = "0.7", features = ["codec"] }
-url = "2.3"
-uuid = { version = "1.3", features = ["v4"] }
+url = "2.4"
+uuid = { version = "1.4", features = ["v4"] }