aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4c8ed51..b42333d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,12 +2,13 @@
name = "budget"
version = "0.1.0"
authors = ["Joris <joris@guyonvarch.me>"]
-edition = "2018"
+edition = "2021"
[dependencies]
bcrypt = "0.13"
chrono = "0.4"
-env_logger = "0.9"
+clap = { version = "4.1", features = ["derive"] }
+env_logger = "0.10"
hyper = { version = "0.14", features = ["full"] }
log = "0.4"
serde = { version = "1.0", features = ["derive"] }
@@ -16,9 +17,8 @@ serde_urlencoded = "0.7"
sha2 = "0.10"
sqlx = { version = "0.6", features = ["runtime-tokio-rustls", "sqlite", "chrono"] }
sqlx-core = "0.6"
-structopt = "0.3"
tera = { version = "1.17", features = ["builtins"] }
tokio = { version = "1", features = ["full"] }
tokio-util = { version = "0.7", features = ["codec"] }
-url = "2.2"
-uuid = { version = "1.1", features = ["v4"] }
+url = "2.3"
+uuid = { version = "1.2", features = ["v4"] }