aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..796a8df
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,30 @@
+with (import (builtins.fetchGit {
+ name = "nixpkgs-20.09";
+ url = "git@github.com:nixos/nixpkgs.git";
+ rev = "cd63096d6d887d689543a0b97743d28995bc9bc3";
+ ref = "refs/tags/20.09";
+}){});
+
+let nixpkgs-mozilla = fetchFromGitHub {
+ owner = "mozilla";
+ repo = "nixpkgs-mozilla";
+ # commit from 2020-10-28
+ rev = "8c007b60731c07dd7a052cce508de3bb1ae849b4";
+ sha256 = "1zybp62zz0h077zm2zmqs2wcg3whg6jqaah9hcl1gv4x8af4zhs6";
+}; in
+
+with import "${nixpkgs-mozilla.out}/rust-overlay.nix" pkgs pkgs;
+
+pkgs.mkShell {
+
+ buildInputs = [
+ # rustChannels.nightly.rust
+ ((rustChannelOf { channel = "1.49.0"; }).rust)
+ cargo-watch
+ lld
+ openssl
+ pkgconfig
+ sqlite
+ ];
+
+}