aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJoris2021-11-20 23:02:52 +0100
committerJoris2021-11-20 23:02:52 +0100
commit54bcca5c48b4586433a92fe4aad9cddd2e5500dc (patch)
treea801bb678569361bce1ca1ef4dd1f3d441f1336e /flake.nix
parent3d58569568ae476e4352f16d48904582f6514b6d (diff)
downloadcalendar-54bcca5c48b4586433a92fe4aad9cddd2e5500dc.tar.gz
calendar-54bcca5c48b4586433a92fe4aad9cddd2e5500dc.tar.bz2
calendar-54bcca5c48b4586433a92fe4aad9cddd2e5500dc.zip
Show event-less calendar
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..b146d72
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,31 @@
+{
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ flake-utils.url = "github:numtide/flake-utils";
+ rust-overlay.url = "github:oxalica/rust-overlay";
+ rust-overlay.inputs.nixpkgs.follows = "nixpkgs";
+ rust-overlay.inputs.flake-utils.follows = "flake-utils";
+ };
+
+ outputs = { self, nixpkgs, rust-overlay, flake-utils, ... }:
+ flake-utils.lib.eachDefaultSystem (system:
+ let
+ overlays = [ (import rust-overlay) ];
+ pkgs = import nixpkgs {
+ inherit system overlays;
+ };
+ in
+ with pkgs;
+ {
+ devShell = mkShell {
+ buildInputs = [
+ rust-bin.stable."1.56.1".default
+ cargo-watch
+ pkgconfig
+ graphene
+ gtk4
+ ];
+ };
+ }
+ );
+}