aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 7 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6426ea6..a0d6f2c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,18 +1,17 @@
[package]
name = "calendar"
version = "1.2.0"
-authors = ["Joris GUYONVARCH"]
-edition = "2018"
+edition = "2021"
[dependencies]
anyhow = "1.0"
-async-channel = "1.6"
+async-channel = "1.8"
chrono = { version = "0.4", features = [ "serde" ] }
-gtk4 = { version = "0.4", features = [ "v4_2" ] }
-rusqlite = { version = "0.26", features = [ "chrono" ] }
-rusqlite_migration = "0.5"
+clap = { version = "4.0", features = ["derive"] }
+gtk4 = { version = "0.5", features = [ "v4_4" ] }
+rusqlite = { version = "0.28", features = [ "chrono" ] }
+rusqlite_migration = "1.0"
serde = { version = "1.0", features = [ "derive" ] }
serde_json = "1.0"
-structopt = "0.3"
thiserror = "1.0"
-uuid = { version = "0.8", features = [ "v4" ] }
+uuid = { version = "1.2", features = [ "v4" ] }