aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/shell.nix b/shell.nix
index 9b7de69..b3241ff 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,15 +1,15 @@
-with import <nixpkgs> {}; {
+with (import (builtins.fetchGit {
+ url = "git@github.com:nixos/nixpkgs.git";
+ rev = "4ea4cd99058d07538935bd55e08802395c295794";
+}){});
+
+{
env = stdenv.mkDerivation {
name = "env";
+
buildInputs = [
elmPackages.elm
nodejs
- tmux
- tmuxinator
];
- shellHook = ''
- tmux kill-session -t catchvoid >/dev/null 2>&1
- tmuxinator local
- '';
};
}