aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJoris2022-07-10 14:17:39 +0200
committerJoris2022-07-10 14:31:36 +0200
commitc1e387f2f84014cc7872b5cfcc5865fd2db2b968 (patch)
tree3f3fcb2fb288644d34703504bb22c3ae3b5e2387 /flake.nix
parent0a9981f655c99833f247e49699ff480aecc4c5be (diff)
downloadcooking-c1e387f2f84014cc7872b5cfcc5865fd2db2b968.tar.gz
cooking-c1e387f2f84014cc7872b5cfcc5865fd2db2b968.tar.bz2
cooking-c1e387f2f84014cc7872b5cfcc5865fd2db2b968.zip
Write recipes in markdown and transform with pandoc
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..e666d54
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,22 @@
+{
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = { self, nixpkgs, flake-utils }:
+ flake-utils.lib.eachDefaultSystem
+ (system:
+ let pkgs = nixpkgs.legacyPackages.${system};
+ in {
+ devShell = pkgs.mkShell {
+ buildInputs = with pkgs; [
+ pandoc
+ psmisc # fuser
+ python3
+ watchexec
+ ];
+ };
+ }
+ );
+}