aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2019-08-21 12:50:51 +0200
committerJoris2019-08-21 12:50:51 +0200
commit2814b04e7bbc187d6b9e0162f11a404379890d07 (patch)
tree2066fbdf4eed365e347e08b5a3aae37d0b474071 /shell.nix
parenta7e57e1d54e97aa75b7226876dae1e46d7cc2074 (diff)
downloadcooking-2814b04e7bbc187d6b9e0162f11a404379890d07.tar.gz
cooking-2814b04e7bbc187d6b9e0162f11a404379890d07.tar.bz2
cooking-2814b04e7bbc187d6b9e0162f11a404379890d07.zip
Add cleaning section
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..37fad5d
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,20 @@
+with (import <nixpkgs> {});
+
+haskell.lib.buildStackProject {
+ name = "myenv";
+
+ buildInputs = [
+ zlib
+ stack
+ psc-package
+ (callPackage ./nix/purescript.nix {})
+ nodePackages.nodemon
+ tmux
+ tmuxinator
+ nodejs-8_x
+ ];
+
+ shellHook = ''
+ export PATH=node_modules/.bin:$PATH;
+ '';
+}