aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2020-02-03 18:28:50 +0100
committerJoris2020-02-03 18:28:50 +0100
commitcbcc269be607cc964fbd69d179d8a0e8b8e4bffa (patch)
tree7a8135f7ede7e1ff02bc1cf1d697a8c39a56e962 /shell.nix
parentc7e20a6dd01a2ae049c451d18511708aaee60a19 (diff)
downloadcooking-cbcc269be607cc964fbd69d179d8a0e8b8e4bffa.tar.gz
cooking-cbcc269be607cc964fbd69d179d8a0e8b8e4bffa.tar.bz2
cooking-cbcc269be607cc964fbd69d179d8a0e8b8e4bffa.zip
Extract dom and number utilities to external files
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 15ea369..02dacb8 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,11 +1,20 @@
with import (builtins.fetchTarball {
url = https://github.com/NixOS/nixpkgs/archive/19.09.tar.gz;
sha256 = "0mhqhq21y5vrr1f30qd2bvydv4bbbslvyzclhw0kdxmkgg3z4c92";
-}) {};
+}) {
+ overlays = [
+ (self: super: {
+ nodePackages = import ./nix/nodePackages {};
+ })
+ ];
+};
+
mkShell {
buildInputs = [
- closurecompiler
+ entr
+ nodePackages.rollup
+ nodePackages.terser
nodePackages.typescript
tmux
tmuxinator