aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix35
1 files changed, 19 insertions, 16 deletions
diff --git a/default.nix b/default.nix
index 17084f8..37fad5d 100644
--- a/default.nix
+++ b/default.nix
@@ -1,17 +1,20 @@
-with import <nixpkgs> {}; {
- env = stdenv.mkDerivation {
- name = "env";
- buildInputs = with pkgs; [
- stack
- psc-package
- (callPackage ./nix/purescript.nix {})
- nodePackages.nodemon
- tmux
- tmuxinator
- nodejs-8_x
- ];
- shellHook = ''
- export PATH=node_modules/.bin:$PATH;
- '';
- };
+with (import <nixpkgs> {});
+
+haskell.lib.buildStackProject {
+ name = "myenv";
+
+ buildInputs = [
+ zlib
+ stack
+ psc-package
+ (callPackage ./nix/purescript.nix {})
+ nodePackages.nodemon
+ tmux
+ tmuxinator
+ nodejs-8_x
+ ];
+
+ shellHook = ''
+ export PATH=node_modules/.bin:$PATH;
+ '';
}