aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJoris2019-04-26 20:10:09 +0200
committerJoris2019-04-26 20:10:09 +0200
commitca31e0ee11d05b3250aa35db5baa0b155939bbbd (patch)
tree12660ef11a65264fa836f0dc583c4e7cc07e518e /default.nix
parent142e0c9fac9896f8cb134fd1e1b010753402e7b8 (diff)
downloadcooking-ca31e0ee11d05b3250aa35db5baa0b155939bbbd.tar.gz
cooking-ca31e0ee11d05b3250aa35db5baa0b155939bbbd.tar.bz2
cooking-ca31e0ee11d05b3250aa35db5baa0b155939bbbd.zip
Add tortillas recipe
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix35
1 files changed, 19 insertions, 16 deletions
diff --git a/default.nix b/default.nix
index 17084f8..37fad5d 100644
--- a/default.nix
+++ b/default.nix
@@ -1,17 +1,20 @@
-with import <nixpkgs> {}; {
- env = stdenv.mkDerivation {
- name = "env";
- buildInputs = with pkgs; [
- stack
- psc-package
- (callPackage ./nix/purescript.nix {})
- nodePackages.nodemon
- tmux
- tmuxinator
- nodejs-8_x
- ];
- shellHook = ''
- export PATH=node_modules/.bin:$PATH;
- '';
- };
+with (import <nixpkgs> {});
+
+haskell.lib.buildStackProject {
+ name = "myenv";
+
+ buildInputs = [
+ zlib
+ stack
+ psc-package
+ (callPackage ./nix/purescript.nix {})
+ nodePackages.nodemon
+ tmux
+ tmuxinator
+ nodejs-8_x
+ ];
+
+ shellHook = ''
+ export PATH=node_modules/.bin:$PATH;
+ '';
}