aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJoris2019-02-02 17:14:33 +0100
committerJoris2019-02-02 17:14:33 +0100
commit142e0c9fac9896f8cb134fd1e1b010753402e7b8 (patch)
tree6315c75f5d8a2a0c4f6e6b7251f621fde933ac9f /default.nix
parentfb470f57438047ac8bd635dc485881ebae4ab0ff (diff)
downloadcooking-142e0c9fac9896f8cb134fd1e1b010753402e7b8.tar.gz
cooking-142e0c9fac9896f8cb134fd1e1b010753402e7b8.tar.bz2
cooking-142e0c9fac9896f8cb134fd1e1b010753402e7b8.zip
Make it works and add “galette” recipe
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..17084f8
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,17 @@
+with import <nixpkgs> {}; {
+ env = stdenv.mkDerivation {
+ name = "env";
+ buildInputs = with pkgs; [
+ stack
+ psc-package
+ (callPackage ./nix/purescript.nix {})
+ nodePackages.nodemon
+ tmux
+ tmuxinator
+ nodejs-8_x
+ ];
+ shellHook = ''
+ export PATH=node_modules/.bin:$PATH;
+ '';
+ };
+}