aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..17084f8
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,17 @@
+with import <nixpkgs> {}; {
+ env = stdenv.mkDerivation {
+ name = "env";
+ buildInputs = with pkgs; [
+ stack
+ psc-package
+ (callPackage ./nix/purescript.nix {})
+ nodePackages.nodemon
+ tmux
+ tmuxinator
+ nodejs-8_x
+ ];
+ shellHook = ''
+ export PATH=node_modules/.bin:$PATH;
+ '';
+ };
+}