aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoris2022-02-13 09:30:42 +0100
committerJoris2022-02-13 09:30:42 +0100
commit8170fb5e432cc81986479a6a3a400e009426d76a (patch)
tree18fe059613547024212aa1f192d83c6df1543fa4 /Cargo.toml
parentc001d6ec59221b11af8e7aafce76002cc63604e6 (diff)
downloadflashcards-8170fb5e432cc81986479a6a3a400e009426d76a.tar.gz
flashcards-8170fb5e432cc81986479a6a3a400e009426d76a.tar.bz2
flashcards-8170fb5e432cc81986479a6a3a400e009426d76a.zip
Properly shuffle card presentation from card insertion
Instead of messing with deck_read, subtracting a random amount of seconds to it, pick a random card instead of the first ready. This permits to remove the dependency to the rand crate.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 95f0f5c..ce79a66 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,7 +7,6 @@ edition = "2018"
[dependencies]
anyhow = "1.0"
chrono = "0.4"
-rand = "0.8"
rusqlite = { version = "0.26", features = [ "chrono" ] }
rusqlite_migration = "0.5"
serde = { version = "1.0", features = ["derive"] }