aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJoris2021-11-14 23:25:55 +0100
committerJoris2021-11-19 11:42:20 +0100
commit9f94611a42d41cf94cdccb00b5d2eec0d5d02970 (patch)
tree9bab5bc342e22aa38b13a2dbd3525bbfe2beedb5 /flake.nix
parent59c44b15010eea5490896a5b5d427b415ad6f56a (diff)
downloadflashcards-9f94611a42d41cf94cdccb00b5d2eec0d5d02970.tar.gz
flashcards-9f94611a42d41cf94cdccb00b5d2eec0d5d02970.tar.bz2
flashcards-9f94611a42d41cf94cdccb00b5d2eec0d5d02970.zip
Add initial working version
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..a7238d3
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,30 @@
+{
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ flake-utils.url = "github:numtide/flake-utils";
+ rust-overlay.url = "github:oxalica/rust-overlay";
+ rust-overlay.inputs.nixpkgs.follows = "nixpkgs";
+ rust-overlay.inputs.flake-utils.follows = "flake-utils";
+ };
+
+ outputs = { self, nixpkgs, rust-overlay, flake-utils, ... }:
+ flake-utils.lib.eachDefaultSystem (system:
+ let
+ overlays = [ (import rust-overlay) ];
+ pkgs = import nixpkgs {
+ inherit system overlays;
+ };
+ in
+ with pkgs;
+ {
+ devShell = mkShell {
+ buildInputs = [
+ rust-bin.stable."1.56.1".default
+ watchexec
+ cargo-watch
+ sqlite
+ ];
+ };
+ }
+ );
+}