aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ce79a66..1489c6f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,15 +2,15 @@
name = "flashcards"
version = "0.1.0"
authors = ["Joris GUYONVARCH"]
-edition = "2018"
+edition = "2021"
[dependencies]
anyhow = "1.0"
chrono = "0.4"
-rusqlite = { version = "0.26", features = [ "chrono" ] }
-rusqlite_migration = "0.5"
+clap = { version = "4.1", features = ["derive"] }
+crossterm = "0.25"
+rusqlite = { version = "0.28", features = [ "chrono" ] }
+rusqlite_migration = "1.0"
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
-structopt = "0.3"
-termion = "1.5"
-tui = "0.16"
+tui = "0.19"