aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..45261c8
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,17 @@
+with import <nixpkgs> {};
+
+let unstable = import (
+ fetchTarball https://github.com/NixOS/nixpkgs-channels/archive/nixos-unstable.tar.gz
+ ) {};
+in
+
+mkShell {
+ buildInputs = [
+ entr
+ gzip
+ python3
+ rustup
+ unstable.binaryen
+ wasm-pack
+ ];
+}