aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJoris2022-09-04 16:21:18 +0200
committerJoris2022-09-04 16:21:18 +0200
commit0b32b9110dd406ca052cfd7348f0ddd7e35b048e (patch)
tree11e0da7d61be8d7602c53b95d1738a87b2179dd2 /flake.nix
parenta5f8943c7eecd2048007b53610d7bc1edaa5ac05 (diff)
Use esbuild to produce JS
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..9ba146e
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,22 @@
+{
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = { self, nixpkgs, flake-utils }:
+ flake-utils.lib.eachDefaultSystem
+ (system:
+ let pkgs = nixpkgs.legacyPackages.${system};
+ in { devShell = pkgs.mkShell {
+ buildInputs = with pkgs; [
+ nodePackages.typescript
+ python3
+ python3Packages.beautifulsoup4
+ psmisc # fuser
+ esbuild
+ watchexec
+ ];
+ }; }
+ );
+}