aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2017-04-04 23:40:54 +0200
committerJoris2017-04-04 23:42:42 +0200
commitf6a73e5bd6a5e2d7d4eb9c8a14bdf1a0c8a4ac4c (patch)
tree184b0ef41ad60dcc9e5cc927604c031e0db81bbf /shell.nix
parent6228c242fda7b33bc919f2a74509314d1e671d4b (diff)
Bootstrap purescript
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..283438f
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,16 @@
+with import <nixpkgs> {}; {
+ env = stdenv.mkDerivation {
+ name = "env";
+ buildInputs = with pkgs; [
+ nodejs-7_x
+ nodePackages.bower
+ purescript
+ tmux
+ tmuxinator
+ webfs
+ ];
+ shellHook = ''
+ export PATH=node_modules/.bin:$PATH;
+ '';
+ };
+}