aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJoris2023-12-27 18:21:37 +0100
committerJoris2023-12-27 18:21:37 +0100
commit98eca7d594960aa616786cbd491b937d50f55499 (patch)
treedb63132d159d09bed2b0a6454c822c2ed95091c6 /flake.nix
parent57da196f828352b009ca86dca98e352cf09663f3 (diff)
First version with 2 songs
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..4b24639
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,21 @@
+{
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = { self, nixpkgs, flake-utils }:
+ flake-utils.lib.eachDefaultSystem
+ (system:
+ let pkgs = nixpkgs.legacyPackages.${system};
+ in {
+ devShell = pkgs.mkShell {
+ buildInputs = with pkgs; [
+ psmisc # fuser
+ sbcl
+ watchexec
+ ];
+ };
+ }
+ );
+}