aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2020-01-20 23:01:58 +0100
committerJoris2020-01-20 23:01:58 +0100
commit6612972e0f8164bd5d062792ba175e1876e4084f (patch)
treeea2b5914e9ece507bd1bc0afb7c7ff8d65b1de17 /shell.nix
parentf4dc1c6196388168eb99b86f5fab7c865cb9cf45 (diff)
Update shared cost tools
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..aaa4ebd
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,18 @@
+with (import <nixpkgs> {});
+
+haskell.lib.buildStackProject {
+ name = "myenv";
+
+ buildInputs = [
+ zlib
+ stack
+ nodePackages.nodemon
+ tmux
+ tmuxinator
+ nodejs
+ ];
+
+ shellHook = ''
+ export PATH=node_modules/.bin:$PATH;
+ '';
+}