aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..aaa4ebd
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,18 @@
+with (import <nixpkgs> {});
+
+haskell.lib.buildStackProject {
+ name = "myenv";
+
+ buildInputs = [
+ zlib
+ stack
+ nodePackages.nodemon
+ tmux
+ tmuxinator
+ nodejs
+ ];
+
+ shellHook = ''
+ export PATH=node_modules/.bin:$PATH;
+ '';
+}