aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..ee5c1cc
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,29 @@
+with (import (builtins.fetchGit {
+ name = "nixpkgs-20.03";
+ url = "git@github.com:nixos/nixpkgs.git";
+ rev = "5272327b81ed355bbed5659b8d303cf2979b6953";
+ ref = "refs/tags/20.03";
+}) {});
+
+let nixpkgs-mozilla = fetchFromGitHub {
+ owner = "mozilla";
+ repo = "nixpkgs-mozilla";
+ # commit from: 2020-01-31
+ rev = "969a1e467abbb91affbf0c24ddf773d2bdf70ccd";
+ sha256 = "13j54pzd9sfyimcmzl0hahzhvr930kiqj839nyk7yxp3nr0zy2xx";
+ };
+in
+
+with import "${nixpkgs-mozilla.out}/rust-overlay.nix" pkgs pkgs;
+
+pkgs.mkShell {
+
+ buildInputs = [
+ ((rustChannelOf { channel = "1.43.1"; }).rust.override {
+ targets = [ "x86_64-unknown-linux-musl" ];
+ })
+ cargo-watch
+ pkgconfig openssl
+ ];
+
+}