aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix16
1 files changed, 9 insertions, 7 deletions
diff --git a/shell.nix b/shell.nix
index ad4a34d..6b652d6 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,16 +1,18 @@
-with (import (builtins.fetchGit {
- name = "nixpkgs-20.09";
- url = "git@github.com:nixos/nixpkgs.git";
- rev = "cd63096d6d887d689543a0b97743d28995bc9bc3";
- ref = "refs/tags/20.09";
-}){});
+with import (builtins.fetchGit {
+ name = "nixos-21.05-2021-08-02";
+ url = "https://github.com/nixos/nixpkgs/";
+ ref = "refs/heads/nixos-21.05";
+ rev = "d4590d21006387dcb190c516724cb1e41c0f8fdf";
+}) {};
mkShell {
buildInputs = [
nodePackages.typescript
python3
- psmisc # fuser
+ psmisc
+ esbuild
+ watchexec
];
}