aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..ad4a34d
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,16 @@
+with (import (builtins.fetchGit {
+ name = "nixpkgs-20.09";
+ url = "git@github.com:nixos/nixpkgs.git";
+ rev = "cd63096d6d887d689543a0b97743d28995bc9bc3";
+ ref = "refs/tags/20.09";
+}){});
+
+mkShell {
+
+ buildInputs = [
+ nodePackages.typescript
+ python3
+ psmisc # fuser
+ ];
+
+}