aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2020-02-16 22:45:07 +0100
committerJoris2020-02-17 09:15:11 +0100
commit25afb0bde9b8a2c064135a534231c232a461b341 (patch)
tree5ab25640024238a2f6f2d176e5870178f18b5345 /shell.nix
parent0366f8cd49d2db40ea5efc639f6a475ecd97675e (diff)
Set up a first version of tabata timer
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..a2d442a
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,17 @@
+with import (builtins.fetchTarball {
+ # https://github.com/NixOS/nixpkgs/commit/77752c6c086512a7c1eb066edcef731696fa2a8e
+ name = "nixpkgs-20-12-2019";
+ url = https://github.com/nixos/nixpkgs/archive/77752c6c086512a7c1eb066edcef731696fa2a8e.tar.gz;
+ sha256 = "1sb6c9pzq4rjc8sj41qw01b38119xk91pmlxwl80fqhg8mj1ai8r";
+}) {};
+
+mkShell {
+ buildInputs = [
+ bs-platform
+ nodejs
+ tmux
+ tmuxinator
+ ocamlformat
+ python3
+ ];
+}