aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix21
1 files changed, 10 insertions, 11 deletions
diff --git a/shell.nix b/shell.nix
index a2d442a..ad4a34d 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,17 +1,16 @@
-with import (builtins.fetchTarball {
- # https://github.com/NixOS/nixpkgs/commit/77752c6c086512a7c1eb066edcef731696fa2a8e
- name = "nixpkgs-20-12-2019";
- url = https://github.com/nixos/nixpkgs/archive/77752c6c086512a7c1eb066edcef731696fa2a8e.tar.gz;
- sha256 = "1sb6c9pzq4rjc8sj41qw01b38119xk91pmlxwl80fqhg8mj1ai8r";
-}) {};
+with (import (builtins.fetchGit {
+ name = "nixpkgs-20.09";
+ url = "git@github.com:nixos/nixpkgs.git";
+ rev = "cd63096d6d887d689543a0b97743d28995bc9bc3";
+ ref = "refs/tags/20.09";
+}){});
mkShell {
+
buildInputs = [
- bs-platform
- nodejs
- tmux
- tmuxinator
- ocamlformat
+ nodePackages.typescript
python3
+ psmisc # fuser
];
+
}