aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2020-11-01 13:42:56 +0100
committerJoris2020-11-01 13:42:56 +0100
commit87e288cd01fbd04675a562bca582f7c2e591c010 (patch)
tree5cb92d3cc6b4b084516fddf32ce30bcb25f2c335 /shell.nix
parentadaec3d1925477e0922bf6ed88a708db4c97d766 (diff)
Improve a bit
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix28
1 files changed, 14 insertions, 14 deletions
diff --git a/shell.nix b/shell.nix
index d3365c2..207a310 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,15 +1,15 @@
-with import <nixpkgs> {}; {
- env = stdenv.mkDerivation {
- name = "env";
- buildInputs = [
- elmPackages.elm
- nodejs
- tmux
- tmuxinator
- ];
- shellHook = ''
- tmux kill-session -t timer >/dev/null 2>&1
- tmuxinator local
- '';
- };
+with (import (builtins.fetchGit {
+ name = "nixpkgs-16.09";
+ url = "git@github.com:nixos/nixpkgs.git";
+ rev = "f22817d8d2bc17d2bcdb8ac4308a4bce6f5d1d2b";
+ ref = "refs/tags/16.09";
+}){});
+
+stdenv.mkDerivation {
+ name = "env";
+ buildInputs = [
+ elmPackages.elm
+ python2
+ python2Packages.pywatchman
+ ];
}