aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2022-07-05 15:05:22 +0200
committerJoris2022-07-05 15:05:22 +0200
commitf02ff6b9a988db111e0384640876f20ecd0e8293 (patch)
tree2e40a88a8f10887dc985be18033682bb369ec179 /shell.nix
parent650a23ed763d8627af14ed154fdb9097a80875c5 (diff)
downloadad-listener-f02ff6b9a988db111e0384640876f20ecd0e8293.tar.gz
ad-listener-f02ff6b9a988db111e0384640876f20ecd0e8293.tar.bz2
ad-listener-f02ff6b9a988db111e0384640876f20ecd0e8293.zip
Simplify tooling
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix27
1 files changed, 16 insertions, 11 deletions
diff --git a/shell.nix b/shell.nix
index afe339f..997bd76 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,12 +1,17 @@
-with import <nixpkgs> {}; {
- env = stdenv.mkDerivation {
- name = "env";
- buildInputs = with nodePackages; with haskellPackages; [
- stack
- nodemon
- stylish-haskell
- tmux
- tmuxinator
- ];
- };
+with (import (builtins.fetchGit {
+ name = "nixos-21.05-2021-08-02";
+ url = "https://github.com/nixos/nixpkgs/";
+ ref = "refs/heads/nixos-21.05";
+ rev = "d4590d21006387dcb190c516724cb1e41c0f8fdf";
+}){});
+
+mkShell {
+
+ buildInputs = with haskellPackages; [
+ cabal-install
+ stylish-haskell
+ tmux
+ (ghc.withPackages (hp: [ hp.zlib ]))
+ ];
+
}