aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix27
1 files changed, 16 insertions, 11 deletions
diff --git a/shell.nix b/shell.nix
index afe339f..997bd76 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,12 +1,17 @@
-with import <nixpkgs> {}; {
- env = stdenv.mkDerivation {
- name = "env";
- buildInputs = with nodePackages; with haskellPackages; [
- stack
- nodemon
- stylish-haskell
- tmux
- tmuxinator
- ];
- };
+with (import (builtins.fetchGit {
+ name = "nixos-21.05-2021-08-02";
+ url = "https://github.com/nixos/nixpkgs/";
+ ref = "refs/heads/nixos-21.05";
+ rev = "d4590d21006387dcb190c516724cb1e41c0f8fdf";
+}){});
+
+mkShell {
+
+ buildInputs = with haskellPackages; [
+ cabal-install
+ stylish-haskell
+ tmux
+ (ghc.withPackages (hp: [ hp.zlib ]))
+ ];
+
}