aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoris2023-08-12 22:20:23 +0200
committerJoris2023-08-12 22:51:07 +0200
commit273bed103c37c81d477998a46873437733ffc16e (patch)
tree38476ed04c58d49207f5b4b61c651c1b72188a8a /Cargo.toml
parent8c689db1c8fa06ddb9119e626e7b1149f3493905 (diff)
downloadbudget-273bed103c37c81d477998a46873437733ffc16e.tar.gz
budget-273bed103c37c81d477998a46873437733ffc16e.tar.bz2
budget-273bed103c37c81d477998a46873437733ffc16e.zip
Generate crypto random token instead of uuid
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c9a2db0..9451df3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,6 +13,8 @@ hmac = "0.12"
hex = "0.4"
hyper = { version = "0.14", features = ["full"] }
log = "0.4"
+rand = { version = "0.8", features = ["getrandom"] }
+rand_core = "0.6.0"
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
serde_urlencoded = "0.7"