aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2017-09-24 22:14:48 +0200
committerJoris2017-11-07 09:33:01 +0100
commit898e7ed11ab0958fcdaf65b99b33f7b04787630a (patch)
tree8b5ab951c36d7d27550a7c4eaad16bbd2cd0edb1 /shell.nix
parent14bdbc8c937f5d0b35c61350dba28cb41c3737cd (diff)
downloadbudget-898e7ed11ab0958fcdaf65b99b33f7b04787630a.tar.gz
budget-898e7ed11ab0958fcdaf65b99b33f7b04787630a.tar.bz2
budget-898e7ed11ab0958fcdaf65b99b33f7b04787630a.zip
Bootstrap with GHCJS and reflex:
- setup login and logout, - first draft of payment view.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 83935d8..23a7255 100644
--- a/shell.nix
+++ b/shell.nix
@@ -5,9 +5,13 @@ with import <nixpkgs> {}; {
elmPackages.elm
nodePackages.nodemon
sqlite
- stack
+ cabal-install
+ cabal2nix
tmux
tmuxinator
];
+ shellHook = ''
+ export PATH=node_modules/.bin:$PATH;
+ '';
};
}