aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2016-10-30 20:27:16 +0100
committerJoris2016-10-30 20:27:16 +0100
commita0ee1260e7efaf6248df9445d4d7165e2fc16cae (patch)
treeea9250ca96459041a45aea619f9a8741643ff7ee /shell.nix
parente899cecde7fb10b5e7ae1b6130922437297f5cb0 (diff)
downloadbudget-a0ee1260e7efaf6248df9445d4d7165e2fc16cae.tar.gz
budget-a0ee1260e7efaf6248df9445d4d7165e2fc16cae.tar.bz2
budget-a0ee1260e7efaf6248df9445d4d7165e2fc16cae.zip
Simplify build
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..83ba9fb
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,46 @@
+with import <nixpkgs> {}; {
+ env = stdenv.mkDerivation {
+ name = "env";
+ buildInputs = with pkgs; [
+ elmPackages.elm
+ cabal-install
+ cabal2nix
+ nodejs
+ sqlite
+ tmux
+ tmuxinator
+ nodePackages.nodemon
+ (haskellPackages.ghcWithPackages (p: with p; [
+ scotty
+ wai
+ wai-middleware-static
+ http-types
+ http-conduit
+ time
+ text
+ blaze-builder
+ cookie
+ bytestring
+ persistent
+ persistent-sqlite
+ persistent-template
+ monad-logger
+ resourcet
+ transformers
+ blaze-html
+ clay
+ aeson
+ clientsession
+ uuid
+ mime-mail
+ mtl
+ lens
+ parsec
+ unordered-containers
+ containers
+ email-validate
+ config-manager
+ ]))
+ ];
+ };
+}