aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..83ba9fb
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,46 @@
+with import <nixpkgs> {}; {
+ env = stdenv.mkDerivation {
+ name = "env";
+ buildInputs = with pkgs; [
+ elmPackages.elm
+ cabal-install
+ cabal2nix
+ nodejs
+ sqlite
+ tmux
+ tmuxinator
+ nodePackages.nodemon
+ (haskellPackages.ghcWithPackages (p: with p; [
+ scotty
+ wai
+ wai-middleware-static
+ http-types
+ http-conduit
+ time
+ text
+ blaze-builder
+ cookie
+ bytestring
+ persistent
+ persistent-sqlite
+ persistent-template
+ monad-logger
+ resourcet
+ transformers
+ blaze-html
+ clay
+ aeson
+ clientsession
+ uuid
+ mime-mail
+ mtl
+ lens
+ parsec
+ unordered-containers
+ containers
+ email-validate
+ config-manager
+ ]))
+ ];
+ };
+}