aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorJoris2016-07-08 20:11:18 +0200
committerJoris2016-07-08 20:11:18 +0200
commitb54d8e45fc8784d8fa6eaa03f58536b7a19cf70b (patch)
tree94a3b54fc5b03e08067e2ee1c430ccdaffeaf56e /shell.nix
parent52f9fafc65d81fc8f684dee21f895e85a14c8165 (diff)
downloadbudget-b54d8e45fc8784d8fa6eaa03f58536b7a19cf70b.tar.gz
budget-b54d8e45fc8784d8fa6eaa03f58536b7a19cf70b.tar.bz2
budget-b54d8e45fc8784d8fa6eaa03f58536b7a19cf70b.zip
Use tmuxinator in nix shell hook
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix17
1 files changed, 3 insertions, 14 deletions
diff --git a/shell.nix b/shell.nix
index bb656a8..c952e15 100644
--- a/shell.nix
+++ b/shell.nix
@@ -8,23 +8,12 @@ with import <nixpkgs> {}; {
nodejs
sqlite
tmux
+ tmuxinator
];
shellHook = ''
- tmux kill-session -t sharedCost >/dev/null
-
- urxvt -e zsh -c "tmux new-session -s sharedCost" & sleep 0.5
- tmux send-keys -t sharedCost '"$EDITOR" README.md' 'C-m'
-
- tmux split-window -h -t sharedCost
- tmux send-keys -t sharedCost 'make install && make build && make watch' 'C-m'
-
- tmux select-pane -t sharedCost -L
- tmux resize-pane -t sharedCost -R 25
-
+ tmux kill-session -t sharedCost >/dev/null 2>&1
firefox http://localhost:3000/
-
- sleep 0.5
- kill -9 $PPID
+ tmuxinator local
'';
};
}