aboutsummaryrefslogtreecommitdiff
path: root/stylish-haskell/default.nix
diff options
context:
space:
mode:
authorJoris2018-01-03 17:31:20 +0100
committerJoris2018-01-03 17:31:22 +0100
commita4acc2e84158fa822f88a1d0bdddb470708b5809 (patch)
tree3faeb0128a51b437501470bd38be62e6e871e9f3 /stylish-haskell/default.nix
parent49426740e8e0c59040f4f3721a658f225572582b (diff)
downloadbudget-a4acc2e84158fa822f88a1d0bdddb470708b5809.tar.gz
budget-a4acc2e84158fa822f88a1d0bdddb470708b5809.tar.bz2
budget-a4acc2e84158fa822f88a1d0bdddb470708b5809.zip
Modify weelky report and payment search interface
- Add payment balance in weekly report - Show a message and hide pages when the search results in no results - Go to page 1 when the search is updated / erased
Diffstat (limited to 'stylish-haskell/default.nix')
-rw-r--r--stylish-haskell/default.nix44
1 files changed, 0 insertions, 44 deletions
diff --git a/stylish-haskell/default.nix b/stylish-haskell/default.nix
deleted file mode 100644
index bd73cf8..0000000
--- a/stylish-haskell/default.nix
+++ /dev/null
@@ -1,44 +0,0 @@
-{ HUnit, aeson, base, bytestring, containers, directory, fetchFromGitHub
-, filepath, haskell-src-exts, mkDerivation, mtl, optparse-applicative, stdenv
-, strict, stylish-haskell, syb, test-framework, test-framework-hunit, yaml
-}:
-
-let regularDependencies = [
- aeson
- base
- bytestring
- containers
- directory
- filepath
- haskell-src-exts
- mtl
- syb
- yaml
- ];
-in mkDerivation {
- pname = "stylish-haskell";
- version = "0.8.1.0";
-
- src = fetchFromGitHub {
- owner = "jaspervdj";
- repo = "stylish-haskell";
- rev = "dc3a73e82c19ff97a1544840dac8f7f4568b24bc";
- sha256 = "0kx9m3j9w2357ff5y651s9cdbjiyax9fksyf4rk8pzabc0dv6dpg";
- };
-
- isLibrary = true;
- isExecutable = true;
-
- libraryHaskellDepends =
- regularDependencies;
-
- executableHaskellDepends =
- regularDependencies ++ [ optparse-applicative strict stylish-haskell ];
-
- testHaskellDepends =
- regularDependencies ++ [ HUnit test-framework test-framework-hunit ];
-
- homepage = "https://github.com/jaspervdj/stylish-haskell";
- description = "Simple Haskell code prettifier";
- license = stdenv.lib.licenses.bsd3;
- }